Project

General

Profile

Evolution #1492

PHP 8 compatibility

Added by Johan Cwiklinski 5 months ago. Updated about 2 months ago.

Status:
Résolu
Priority:
Haut
Category:
Core
Target version:
Start date:
10/03/2020
Due date:
% Done:

100%

Estimated time:
Vote:

Description

PHP 8-rc1 has been released, some changes may be required in Galette for compatibility.

Main problem is probably not Galette itself; but some dependencies:
- faker: stucked on an old version already patched for php 7.4, upgrading would require to rewrite many unit tests,
- laminas-db: beacause of on old bug on the lib (see #1299)
- pimple: dependency injection no longer maintained; and not compatible with other alternatives... Switching to php-di would be required; I do not see any other solution
- atoum: a php8 patch has been proposed upstream, see https://github.com/atoum/atoum/pull/843

This is an non exhaustive list.


Related issues

Blocked by Galette - R&D #1372: Integrate php-diRésoluJohan Cwiklinski12/03/2019

Actions
Blocked by Galette - Anomalie #1299: Incompatibilité avec zend-db > 2.9.2FerméJohan Cwiklinski09/08/2019

Actions
#1

Updated by Johan Cwiklinski 4 months ago

  • Blocked by R&D #1372: Integrate php-di added
#2

Updated by Johan Cwiklinski 4 months ago

  • Blocked by Anomalie #1299: Incompatibilité avec zend-db > 2.9.2 added
#3

Updated by Johan Cwiklinski about 2 months ago

  • Status changed from Nouveau to Résolu
  • Assignee set to Johan Cwiklinski
  • Target version set to 0.9.5
  • % Done changed from 0 to 100

Also available in: Atom PDF