Project

General

Profile

Actions

Anomalie #1604

open

Les rappels automatiques ne fonctionnent plus

Added by Frederic CROZET 10 months ago. Updated 3 months ago.

Status:
Résolu
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/05/2021
Due date:
% Done:

100%

Estimated time:
Version utilisée:

Description

Hello,
L’envoi des rappels avec une tâche cron ne fonctionne plus depuis la version 0.9.5.1. (idem avec la version 0.9.6.)
Tout fonctionnait bien auparavant avec la version 0.9.4.2.
Après plusieurs tests et essais, la tâche cron est parfaitement fonctionnelle.
Mais aucun rappel n'est envoyé par mail. Je n'ai rien dans les logs.
Je ne sais pas comment tester l'exécution du fichier "reminder.php".

Actions #1

Updated by Frederic CROZET 10 months ago

Je ne l'ai pas précisé mais les rappels manuels fonctionnent toujours à partir de la page "Rappel"
Frédéric

Frederic CROZET a écrit :

Hello,
L’envoi des rappels avec une tâche cron ne fonctionne plus depuis la version 0.9.5.1. (idem avec la version 0.9.6.)
Tout fonctionnait bien auparavant avec la version 0.9.4.2.
Après plusieurs tests et essais, la tâche cron est parfaitement fonctionnelle.
Mais aucun rappel n'est envoyé par mail. Je n'ai rien dans les logs.
Je ne sais pas comment tester l'exécution du fichier "reminder.php".

Actions #2

Updated by Johan Cwiklinski 10 months ago

  • Version utilisée changed from 0.9.6 to 0.9.5

J'ai regardé rapidement, et ça va visiblement être compliqué à corriger... :/

Actions #3

Updated by Frederic CROZET 10 months ago

Merci Johan,
Comme il n'y avait rien dans les logs, je commençais à me poser des questions.
J'ai tout vérifié de mon coté mais j'ai atteint rapidement mes limites :)
Donc cela me rassure...

Johan Cwiklinski a écrit (#note-2):

J'ai regardé rapidement, et ça va visiblement être compliqué à corriger... :/

Actions #4

Updated by Johan Cwiklinski 3 months ago

Proposition de correctif :
https://github.com/galette/galette/pull/191

Les emails partent bien avec ce correctif, j'ai néanmoins identifié un problème : lorsque l'on utilise le logo ou un lien généré dans le contenu du courriel, le lien est invalide... Forcément, piusque Galette depuis l'interface web « devine » l'URL adéquate ; et ce n'est pas possible depuis la ligne de commande (donc les cron).

La seule solution que je voie pour ce problème, c'est d'ajouter un nouveau paramètre dans les préférences pour définir l'URL de base à utiliser depuis la crontab. C'est certes un paramètre supplémentaire à renseigner, mais il semble que vraiment peu de monde utilise la crontab pour les rappels.

Actions #5

Updated by Guillaume Agniéray 3 months ago

Johan Cwiklinski a écrit (#note-4):

La seule solution que je voie pour ce problème, c'est d'ajouter un nouveau paramètre dans les préférences pour définir l'URL de base à utiliser depuis la crontab. C'est certes un paramètre supplémentaire à renseigner, mais il semble que vraiment peu de monde utilise la crontab pour les rappels.

Ou bien définir une nouvelle constante à cet effet dans config.inc.php . Serait-ce possible ?

Actions #6

Updated by Johan Cwiklinski 3 months ago

Guillaume Agniéray a écrit (#note-5):

Ou bien définir une nouvelle constante à cet effet dans config.inc.php . Serait-ce possible ?

Ça me semble une bonne idée, bien vu :)

Actions #7

Updated by Johan Cwiklinski 3 months ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100
Actions #8

Updated by Frederic CROZET 3 months ago

Merci Johan & Guillaume,
Ma tache cron a repris du service depuis ce matin et donc pleinement opérationnelle ;)

Actions #9

Updated by Johan Cwiklinski 3 months ago

Frederic CROZET a écrit (#note-8):

Ma tache cron a repris du service depuis ce matin et donc pleinement opérationnelle ;)

Super, merci pour la confirmation :)

Actions

Also available in: Atom PDF